Current PHP Extensions Required for WordPress 5

PHP Selector allows you to use the version of PHP most appropriate for your site or application. In addition, it allows you to load only the PHP extensions required by your application, in this case WordPress. Many Hosting Providers create a single version of PHP with every known (popular) extension included and then push that single version out to all customers. That creates a bloated and potentially slow and insecure PHP environment. Instead, we allow you to tune your PHP environment to meet the needs of your site. Keeping your PHP extensions to a minimum keeps memory usage low, provides a safer environment and faster load times for your pages and posts.

As of WordPress 5.x and PHP 7.x this is the minimum required set of extensions:

PHP Extensions List:

bcmath
dom
gd
gmagick
json
mbstring
mysqli
posix
sockets
xmlreader
xmlwriter

While this list is accurate as of the time of writing please note that as PHP evolves some extensions are deprecated while others are pulled into core. And as WordPress evolves the need for extensions may also change. We’ll do our best to keep this Live Doc up to date as the world evolves but please check the WordPress docs for specific requirements if you run into any trouble.

2019-02-05T11:17:47+00:00February 5th, 2019|